Конфигурация Интерфейса маршрутизатора

Рассмотрим, как Вы конфигурируете отдельные интерфейсы маршрутизатора с IP-адресами и другой информацией.

Конфигурация Интерфейса маршрутизатора

Во-первых, войдите в интерфейсный режим конфигурации, определяя тип интерфейса и номер. Затем, сконфигурируйте IP-адрес и маску подсети:

R1(config)#interface Serial0/0/0
R1(config-if)#ip address 192.168.2.1 255.255.255.0

Это - хорошая практика, чтобы сконфигурировать описание в каждом интерфейсе, дабы помочь задокументировать сетевую информацию. Текст описания ограничивается 240 символами. В производственных сетях описание может быть полезным в поиске и устранении неисправностей, предоставляя информацию о типе сети, с которой соединяется интерфейс и есть ли какие-либо другие маршрутизаторы в той сети. Если интерфейс соединяется с ISP или поставщиком службы, полезно указать соединение со сторонней организацией и контактную информацию; например:

Router(config-if)#description Ciruit#VBN32696-123 (help desk:1-800-555-1234)

После конфигурирования IP-адреса и описания, интерфейс должен быть активирован командой no shutdown. Это подобно включению интерфейса. Интерфейс должен также быть соединен с другим устройством (концентратор, коммутатор, другой маршрутизатор и т.д.), чтобы Физический уровень был активным.

Router(config-if)#no shutdown

Повторите команды конфигурации интерфейса на всех других интерфейсах, которые должны быть сконфигурированы. В нашем примере топологии должен быть сконфигурирован интерфейс FastEthernet.

R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#description R1 LAN
R1(config-if)#no shutdown

Каждый Интерфейс Принадлежит Различной Сети

Отметьте, что каждый интерфейс должен принадлежать различной сети. Хотя IOS позволяет Вам конфигурировать IP-адрес одной и той же сети в двух различных интерфейсах, маршрутизатор не будет активировать второй интерфейс.

Например, что если Вы пытаетесь сконфигурировать интерфейс FastEthernet 0/1 на R1 с IP-адресом сети в 192.168.1.0/24? FastEthernet 0/0 был уже присвоен адрес той же самой сети. Если Вы попытаетесь сконфигурировать другой интерфейс, FastEthernet 0/1, с IP-адресом, который принадлежит той же самой сети, то Вы получите следующее сообщение:

R1(config)#interface FastEthernet0/1
R1(config-if)#ip address 192.168.1.2 255.255.255.0
192.168.1.0 overlaps with FastEthernet0/0

Если будет попытка включить интерфейс командой no shutdown, то следующее сообщение появится:

R1(config-if)#no shutdown
192.168.1.0 overlaps with FastEthernet0/0
FastEthernet0/1: incorrect IP address assignment

Заметьте, что вывод команды show ip interface brief показывает, что второй интерфейс, сконфигурированный для сети 192.168.1.0/24, FastEthernet 0/1, по-прежнему выключен.

R1#show ip interface brief
<вывод пропущен>
FastEthernet0/1 192.168.1.2 YES manual administratively down down

Далее: Протокол Обнаружения Cisco (CDP)

Смотрите также
Комментарии
Написать

(обязательно)

(обязательно)

Это не спам (обязательно)